Vulnerability · Published Aug 18, 2026 · Assigned by GitHub_M

CVE-2026-52854mediawiki/maps: Stored XSS through the overlays parameter in the display_map parser function

High 8.6

In plain English

A high-severity cross-site scripting in Maps from ProfessionalWiki. Proof-of-concept exploit code is public. The chance it is exploited in the next 30 days is estimated at 0.6% (higher than 48% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)8.6High
Exploit odds (30 days)0.6%top 52.2% of all CVEs
Exploited in the wildNo reportsCISA SSVC: poc
Attack toolingNoneno public tooling known

Official description

Maps is a MediaWiki extension that enables visualization of geographic data through dynamic embedded maps. Prior to version 12.1.3, the display_map parser function in the Leaflet service accepts attacker-controlled HTML in the overlays parameter, and resources/leaflet/jquery.leaflet.js uses the overlay name as a Leaflet layer-control label without escaping it. A wiki user with the edit permission can store malicious wikitext that causes script execution when another user previews or views the affected map. The script executes in the viewing user's browser session and can access data or perform actions available to that user. This issue is fixed in version 12.1.3.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Packagistmediawiki/maps12.1.3GHSA-4h7g-5542-v3fc
Ubuntu:26.04:LTSmediawikino fix listedUBUNTU-CVE-2026-52854
Ubuntu:26.10mediawikino fix listedUBUNTU-CVE-2026-52854

Affected products (as reported)

VendorProductVersions
ProfessionalWiki Maps < 12.1.3

Weakness: CWE-79, CWE-80 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:L/A:L

References