Vulnerability · Published Jun 23, 2026 · Assigned by GitHub_M

CVE-2026-52845Caddy: FastCGI header normalization bypass in `forward_auth copy_headers`

High 8.1

In plain English

A high-severity improper authentication in caddy from caddyserver. Proof-of-concept exploit code is public. The chance it is exploited in the next 30 days is estimated at 0.4% (higher than 39% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)8.1High
Exploit odds (30 days)0.4%top 61.1% of all CVEs
Exploited in the wildNo reportsCISA SSVC: poc
Attack toolingNoneno public tooling known

Official description

Caddy is an extensible server platform that uses TLS by default. Prior to 2.11.4, forward_auth copy_headers deletes the exact client-supplied identity header before copying the trusted value from the auth gateway. But when the request later goes through php_fastcgi, Caddy normalizes HTTP headers into CGI variables by replacing - with _. This lets a client send an underscore alias that survives the forward_auth delete step but becomes the same PHP/FastCGI variable. Result: a remote client can inject or sometimes override identity/group headers trusted by PHP/FastCGI applications behind Caddy. This vulnerability is fixed in 2.11.4.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Debian:12caddy2.6.2-5+deb12u1DEBIAN-CVE-2026-52845
Debian:13caddy2.6.2-12+deb13u1DEBIAN-CVE-2026-52845
Debian:14caddy2.11.4-1DEBIAN-CVE-2026-52845
Gogithub.com/caddyserver/caddyno fix listedGHSA-f59h-q822-g45g
Gogithub.com/caddyserver/caddy/v22.11.4GHSA-f59h-q822-g45g
Gogithub.com/caddyserver/caddy/v22.11.4GO-2026-5346
Ubuntu:25.10caddyno fix listedUBUNTU-CVE-2026-52845
Ubuntu:26.10caddyno fix listedUBUNTU-CVE-2026-52845

Affected products (as reported)

VendorProductVersions
caddyserver caddy < 2.11.4

Weakness: CWE-287, CWE-290, CWE-444 · Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:N

References