Vulnerability · Published Jun 24, 2026 · Assigned by GitHub_M
CVE-2026-52797Gogs: Overwriting critical files results in a denial of service
High 8.5
In plain English
A high-severity path traversal in gogs from gogs. Proof-of-concept exploit code is public. The chance it is exploited in the next 30 days is estimated at 0.5% (higher than 45% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
Gogs is an open source self-hosted Git service. Prior to 0.14.0, as an authorized user, an intruder can dictate the value which is passed to the git diff command which, together with bypassing the filtering of the passed value, allows the user to bypass the target directory and write the result of the comparison to any arbitrary path. This vulnerability is fixed in 0.14.0.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| Go | gogs.io/gogs | 0.14.0 | GHSA-pm6v-2h4w-4rp2 |
| Go | gogs.io/gogs | no fix listed | GO-2026-5545 |
Affected products (as reported)
Weakness: CWE-22 · Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:N/I:L/A:H
References
- https://github.com/gogs/gogs/security/advisories/GHSA-pm6v-2h4w-4rp2 x_refsource_CONFIRM