Vulnerability · Published Jun 25, 2026 · Assigned by GitHub_M
CVE-2026-50573pnpm: Unsafe default behavior breaks integrity check
Medium 6.8
In plain English
A medium-severity insufficient verification of data authenticity in pnpm from pnpm. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.2% (higher than 6% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
pnpm is a package manager. Prior to 10.34.0 and 11.4.0, `pnpm install` in non-frozen mode can accept new remote package content after detecting that the downloaded tarball does not match the integrity recorded in pnpm-lock.yaml. When a package is already locked with an integrity value, and the registry later serves different metadata and tarball content for the same package name and version, pnpm initially reports an integrity mismatch. However, plain pnpm install then performs a resolution repair, accepts the registry's new integrity, updates the lockfile, installs the new content, and exits successfully. This means the lockfile integrity check does not act as a hard stop by default. This vulnerability is fixed in 10.34.0 and 11.4.0.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| npm | pnpm | 10.34.0 | GHSA-54hh-g5mx-jqcp |
| npm | pnpm | 11.4.0 | GHSA-54hh-g5mx-jqcp |
Affected products (as reported)
Weakness: CWE-345 · Vector: CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:H/I:H/A:N
References
- https://github.com/pnpm/pnpm/security/advisories/GHSA-54hh-g5mx-jqcp x_refsource_CONFIRM