Vulnerability · Published Aug 19, 2026 · Assigned by GitHub_M
CVE-2026-50550Snipe-IT: 2FA reset privilege bypass
Medium 5.8
In plain English
A medium-severity incorrect authorization in snipe-it from grokability. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.3% (higher than 19% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
Snipe-IT is an IT asset/license management system. Prior to 8.5.0, a user who can edit other users can reset a superadmin's two-factor authentication through app/Http/Controllers/Api/UsersController.php postTwoFactorReset(). The endpoint authorizes update access but does not enforce canEditAuthFields before clearing two_factor_secret and two_factor_enrolled. This issue is fixed in version 8.5.0.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| Packagist | snipe/snipe-it | 8.5.0 | GHSA-6x4j-8954-5hxm |
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| grokability | snipe-it | < 8.5.0 |
Weakness: CWE-863 · Vector: CVSS:3.1/AV:A/AC:L/PR:L/UI:R/S:U/C:L/I:H/A:N