Vulnerability · Published Aug 31, 2026 · Assigned by GitHub_M
CVE-2026-50199Wallos: Cross-user Fixer/API Layer credential consumption in exchange-rate refresh
Medium 4.3
In plain English
A medium-severity incorrect authorization in Wallos from ellite. Proof-of-concept exploit code is public. The chance it is exploited in the next 30 days is estimated at 0.3% (higher than 18% of all known vulnerabilities).
Official description
Wallos is an open-source, self-hostable personal subscription tracker. Prior to version 4.9.1, endpoints/currency/update_exchange.php loads the first Fixer/API Layer credential globally instead of loading the credential for the authenticated user. As a result, a normal authenticated user without their own provider key can trigger exchange-rate refreshes using another user's stored provider credential. This issue has been patched in version 4.9.1.
Affected products (as reported)
Weakness: CWE-863 · Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:L/A:N
References
- https://github.com/ellite/Wallos/security/advisories/GHSA-5wf4-m4hj-rxj5 x_refsource_CONFIRM
- https://github.com/ellite/Wallos/releases/tag/v4.9.1 x_refsource_MISC