Vulnerability · Published Jul 1, 2026 · Assigned by GitHub_M

CVE-2026-50195containerd: CRI checkpoint import allows local image tag poisoning

Medium 5.6

In plain English

A medium-severity insufficient verification of data authenticity in containerd from containerd. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.3% (higher than 23% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 4.0)5.6Medium
Exploit odds (30 days)0.3%top 76.8% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

containerd is an open-source container runtime. Versions prior to 2.3.2, 2.2.5 and 2.1.9 contain a vulnerability in the CRI checkpoint import process where it fails to validate the image references specified within a checkpoint image's configuration. An attacker with permissions to create pods can use a crafted checkpoint image to force containerd to pull a malicious image and assign it an arbitrary local tag, thereby poisoning the node's local image cache. Subsequently, if other pods on the same node attempt to use the poisoned tag with an IfNotPresent (or Never) pull policy, they will unknowingly execute the attacker's malicious image instead of the legitimate one. This can lead to a compromise of the affected pods, allowing the attacker to execute arbitrary code under the victim pod's identity. This issue has been fixed in versions 2.3.2, 2.2.5 and 2.1.9.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Alpine:v3.24containerd2.3.2-r0ALPINE-CVE-2026-50195
Debian:14containerd2.1.9+ds1-1DEBIAN-CVE-2026-50195
Gogithub.com/containerd/containerdno fix listedGO-2026-5338
Gogithub.com/containerd/containerd/v22.1.9, 2.2.5, 2.3.2GO-2026-5338
Gogithub.com/containerd/containerd/v22.1.9GHSA-cvxm-645q-p574
Gogithub.com/containerd/containerd/v22.2.5GHSA-cvxm-645q-p574
Gogithub.com/containerd/containerd/v22.3.2GHSA-cvxm-645q-p574
Ubuntu:22.04:LTScontainerd-app2.2.1-0ubuntu1~22.04.2UBUNTU-CVE-2026-50195
Ubuntu:24.04:LTScontainerd-app2.2.1-0ubuntu1~24.04.3UBUNTU-CVE-2026-50195
Ubuntu:25.10containerd-app2.2.1-0ubuntu1~25.10.2UBUNTU-CVE-2026-50195
Ubuntu:26.04:LTScontainerd-app2.2.2-0ubuntu1.1UBUNTU-CVE-2026-50195
Ubuntu:25.10containerd-stable2.1.6-0ubuntu1~25.10.2UBUNTU-CVE-2026-50195
Ubuntu:26.04:LTScontainerd-stable2.2.2-0ubuntu1.1UBUNTU-CVE-2026-50195

Affected products (as reported)

VendorProductVersions
containerd containerd >= 2.1.0, < 2.1.9>= 2.2.0, < 2.2.5>= 2.3.0, < 2.3.2

Weakness: CWE-345, CWE-829 · Vector: CVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:N/VC:N/VI:L/VA:N/SC:H/SI:H/SA:L

References