Vulnerability · Published Jun 22, 2026 · Assigned by GitHub_M

CVE-2026-50171Angular: Denial of Service (DoS) via OOM in Number Formatting (digitsInfo)

High 8.2

In plain English

A high-severity uncontrolled resource consumption in angular from angular. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.3% (higher than 17% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 4.0)8.2High
Exploit odds (30 days)0.3%top 82.7% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

Angular is a development platform for building mobile and desktop web applications using TypeScript/JavaScript and other languages. Prior to 22.0.0-rc.2, 21.2.15, 20.3.22, and 19.2.23, a Denial of Service (DoS) vulnerability exists in the @angular/common package of Angular. The formatNumber function, which is also utilized by DecimalPipe, PercentPipe, and CurrencyPipe, does not properly validate the upper bounds of the digitsInfo parameter. Specifically, the minimum and maximum fraction digits parsed from the digitsInfo string (e.g., 1.2-4) are converted to integers and used without limits. When parsing a maliciously crafted digitsInfo string with excessively large fraction digit values (e.g., 1.200000000-200000000), the internal roundNumber function attempts to pad the digits array to match the requested fraction size. This results in an unbounded loop that repeatedly pushes elements into an array. This vulnerability is fixed in 22.0.0-rc.2, 21.2.15, 20.3.22, and 19.2.23.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Debian:12angular.jsno fix listedDEBIAN-CVE-2026-50171
Debian:13angular.jsno fix listedDEBIAN-CVE-2026-50171
Ubuntu:22.04:LTSangular.jsno fix listedUBUNTU-CVE-2026-50171
Ubuntu:24.04:LTSangular.jsno fix listedUBUNTU-CVE-2026-50171
Ubuntu:25.10angular.jsno fix listedUBUNTU-CVE-2026-50171
Ubuntu:26.04:LTSangular.jsno fix listedUBUNTU-CVE-2026-50171
Ubuntu:26.10angular.jsno fix listedUBUNTU-CVE-2026-50171
npm@angular/common21.2.15GHSA-p3vc-36g9-x9gr
npm@angular/commonno fix listedGHSA-p3vc-36g9-x9gr
npm@angular/common19.2.23GHSA-p3vc-36g9-x9gr
npm@angular/common20.3.22GHSA-p3vc-36g9-x9gr
npm@angular/common22.0.0-rc.2GHSA-p3vc-36g9-x9gr

Affected products (as reported)

VendorProductVersions
angular angular >= 22.0.0-next.0, < 22.0.0-rc.2>= 21.0.0-next.0, < 21.2.15>= 20.0.0-next.0, < 20.3.22>= 19.0.0-next.0, < 19.2.23<= 18.2.14

Weakness: CWE-400, CWE-834 · Vector: CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N

References