Vulnerability · Published Jun 22, 2026 · Assigned by GitHub_M

CVE-2026-50170Angular: Information Leak via Default Caching of Credentialed Requests in HttpTransferCache

High 8.2

In plain English

A high-severity security flaw in angular from angular. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.4% (higher than 37% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 4.0)8.2High
Exploit odds (30 days)0.4%top 63.0% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

Angular is a development platform for building mobile and desktop web applications using TypeScript/JavaScript and other languages. Prior to 22.0.0-rc.2, 21.2.15, 20.3.22, and 19.2.23, a vulnerability was discovered in @angular/common when Server-Side Rendering (SSR) and hydration are enabled. The HttpTransferCache utility optimizes hydration by caching outgoing HTTP requests performed during SSR and transferring the cached state to the client-side application via TransferState. However, the caching mechanism fails to inspect the withCredentials flag or the Cookie header of outgoing requests. As a result, credentialed, user-specific responses may be cached by default in the shared TransferState payload. When these responses are serialized into the HTML, any caching layer (such as a CDN, reverse proxy, or shared server cache) that caches the SSR-rendered HTML page could inadvertently cache and leak one user's private data to other users, leading to a high-severity information disclosure vulnerability. This vulnerability is fixed in 22.0.0-rc.2, 21.2.15, 20.3.22, and 19.2.23.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Debian:12angular.jsno fix listedDEBIAN-CVE-2026-50170
Debian:13angular.jsno fix listedDEBIAN-CVE-2026-50170
Ubuntu:22.04:LTSangular.jsno fix listedUBUNTU-CVE-2026-50170
Ubuntu:24.04:LTSangular.jsno fix listedUBUNTU-CVE-2026-50170
Ubuntu:25.10angular.jsno fix listedUBUNTU-CVE-2026-50170
Ubuntu:26.04:LTSangular.jsno fix listedUBUNTU-CVE-2026-50170
Ubuntu:26.10angular.jsno fix listedUBUNTU-CVE-2026-50170
npm@angular/common19.2.23GHSA-q6f4-qqrg-jv6x
npm@angular/commonno fix listedGHSA-q6f4-qqrg-jv6x
npm@angular/common21.2.15GHSA-q6f4-qqrg-jv6x
npm@angular/common20.3.22GHSA-q6f4-qqrg-jv6x
npm@angular/common22.0.0-rc.2GHSA-q6f4-qqrg-jv6x

Affected products (as reported)

VendorProductVersions
angular angular >= 22.0.0-next.0, < 22.0.0-rc.2>= 21.0.0-next.0, < 21.2.15>= 20.0.0-next.0, < 20.3.22>= 19.0.0-next.0, < 19.2.23<= 18.2.14

Weakness: CWE-524 · Vector: CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N

References