Vulnerability · Published Jun 22, 2026 · Assigned by GitHub_M

CVE-2026-50169Angular Service Worker Policy-Bypass & Credential-Stripping Vulnerabilities

Medium 5.7

In plain English

A medium-severity information exposure in angular from angular. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.2% (higher than 14% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 4.0)5.7Medium
Exploit odds (30 days)0.2%top 86.4% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

Angular is a development platform for building mobile and desktop web applications using TypeScript/JavaScript and other languages. Prior to 22.0.0-rc.2, 21.2.15 20.3.22, and 19.2.23, an issue in the @angular/service-worker package compromises the integrity of request-policy enforcement during request reconstruction. When the Angular Service Worker intercepts network requests for matched assets, it reconstructs a new Request object using an internal helper function. During this reconstruction process, the helper function strips the strict, client-defined request redirect policy configuration (such as redirect: 'error'), falling back to the browser's default 'follow' strategy. If the target web application makes client-side requests with a strict policy (e.g., expecting a network error instead of automatically following redirects), the service worker will bypass this instruction and automatically follow HTTP 3xx redirects to other destinations. This acts as an unintended proxy/intermediary ("Confused Deputy") and can result in cookie/credential exposure or same-origin session-restricted data leakage if public dynamic routes redirect to sensitive routes. This vulnerability is fixed in 22.0.0-rc.2, 21.2.15, 20.3.22, and 19.2.23.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Debian:12angular.jsno fix listedDEBIAN-CVE-2026-50169
Debian:13angular.jsno fix listedDEBIAN-CVE-2026-50169
Ubuntu:22.04:LTSangular.jsno fix listedUBUNTU-CVE-2026-50169
Ubuntu:24.04:LTSangular.jsno fix listedUBUNTU-CVE-2026-50169
Ubuntu:25.10angular.jsno fix listedUBUNTU-CVE-2026-50169
Ubuntu:26.04:LTSangular.jsno fix listedUBUNTU-CVE-2026-50169
Ubuntu:26.10angular.jsno fix listedUBUNTU-CVE-2026-50169
npm@angular/service-worker19.2.23GHSA-gv2q-mqqv-365m
npm@angular/service-workerno fix listedGHSA-gv2q-mqqv-365m
npm@angular/service-worker21.2.15GHSA-gv2q-mqqv-365m
npm@angular/service-worker20.3.22GHSA-gv2q-mqqv-365m
npm@angular/service-worker22.0.0-rc.2GHSA-gv2q-mqqv-365m

Affected products (as reported)

VendorProductVersions
angular angular >= 22.0.0-next.0, < 22.0.0-rc.2>= 21.0.0-next.0, < 21.2.15>= 20.0.0-next.0, < 20.3.22>= 19.0.0-next.0, < 19.2.23<= 18.2.14

Weakness: CWE-200, CWE-441, CWE-524 · Vector: CVSS:4.0/AV:L/AC:H/AT:P/PR:N/UI:P/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N

References