Vulnerability · Published Jun 30, 2026 · Assigned by apache

CVE-2026-49877Apache ActiveMQ: Authenticated web users retain admin access by default in the Web Console

High 8.1

In plain English

A high-severity security flaw in Apache ActiveMQ from Apache Software Foundation. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.5% (higher than 44% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)8.1High
Exploit odds (30 days)0.5%top 56.0% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

Improper Authorization vulnerability in Apache ActiveMQ. An authenticated low-privilege Web Console user by default can access /admin/* paths in the Web Console. The default Jetty settings incorrectly did not limit those paths to only admins. This issue affects Apache ActiveMQ: before 5.19.8, from 6.0.0 before 6.2.7. Users are recommended to upgrade to version 6.2.7 or 5.19.8, which fixes the issue.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Debian:12activemqno fix listedDEBIAN-CVE-2026-49877
Debian:13activemqno fix listedDEBIAN-CVE-2026-49877
Mavenorg.apache.activemq:apache-activemq5.19.8GHSA-f892-4h9f-j7g9
Mavenorg.apache.activemq:apache-activemq6.2.7GHSA-f892-4h9f-j7g9
Ubuntu:24.04:LTSactivemqno fix listedUBUNTU-CVE-2026-49877
Ubuntu:25.10activemqno fix listedUBUNTU-CVE-2026-49877
Ubuntu:26.04:LTSactivemqno fix listedUBUNTU-CVE-2026-49877
Ubuntu:26.10activemqno fix listedUBUNTU-CVE-2026-49877

Affected products (as reported)

VendorProductVersions
Apache Software Foundation Apache ActiveMQ 0 – before 5.19.86.0.0 – before 6.2.7

Weakness: CWE-285 · Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:N

References