Vulnerability · Published Sep 2, 2026 · Assigned by GitHub_M
CVE-2026-49833DSpace: Path Traversal possible in LDN message generation
Medium 5.5
In plain English
A medium-severity path traversal in DSpace from DSpace. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.4% (higher than 31% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
DSpace open source software is a repository application which provides durable access to digital resources. From versions 8.0-rc1 to before 8.4, 9.0-rc1 to before 9.3, and 10-rc1 to before 10.0, a path traversal vulnerability is possible via the COAR Notify / LDN service in DSpace. The attacker MUST already have DSpace administrator credentials in order to perform the attack. When reading a file input stream of an "inbound pattern" / "template", used to generate an LDN message, the LDN class does not check for path traversal or restrict the templates to a known base path. This could allow an untrusted file from elsewhere in the file system (e.g. an export log, a bitstream path, a temporary file) to be read and interpreted as an Apache Velocity template. This issue has been patched in versions 8.4, 9.3, and 10.0.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| Maven | org.dspace:dspace-api | 8.4 | GHSA-9qm4-rh6w-pq5x |
| Maven | org.dspace:dspace-api | 9.3 | GHSA-9qm4-rh6w-pq5x |
| Maven | org.dspace:dspace-api | 10.0 | GHSA-9qm4-rh6w-pq5x |
Affected products (as reported)
Weakness: CWE-22 · Vector: CVSS:3.1/AV:N/AC:H/PR:H/UI:N/S:U/C:H/I:L/A:L
References
- https://github.com/DSpace/DSpace/security/advisories/GHSA-9qm4-rh6w-pq5x x_refsource_CONFIRM
- https://github.com/DSpace/DSpace/pull/12540 x_refsource_MISC
- https://github.com/DSpace/DSpace/pull/12552 x_refsource_MISC