Vulnerability · Published Jul 14, 2026 · Assigned by GitHub_M

CVE-2026-49477Soup Sieve: Regular Expression Denial of Service (ReDoS) in soupsieve Selector Parser

High 7.5

In plain English

A high-severity uncontrolled resource consumption in soupsieve from facelessuser. Proof-of-concept exploit code is public. The chance it is exploited in the next 30 days is estimated at 0.6% (higher than 51% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)7.5High
Exploit odds (30 days)0.6%top 48.9% of all CVEs
Exploited in the wildNo reportsCISA SSVC: poc
Attack toolingNoneno public tooling known

Official description

Soup Sieve is a CSS selector library designed to be used with Beautiful Soup 4. Prior to 2.8.4, the CSS selector parser in soupsieve contains a regular expression vulnerable to catastrophic backtracking when processing an attribute selector with an unterminated quoted value in soupsieve/css_parser.py, allowing an attacker who can supply untrusted CSS selector strings to soupsieve.compile() or Beautiful Soup .select() / .select_one() to cause CPU exhaustion and denial of service. This issue is fixed in version 2.8.4.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Debian:12soupsieveno fix listedDEBIAN-CVE-2026-49477
Debian:13soupsieveno fix listedDEBIAN-CVE-2026-49477
Debian:14soupsieve2.8.4-1DEBIAN-CVE-2026-49477
PyPIsoupsieve2.8.4GHSA-836r-79rf-4m37
PyPIsoupsieve2.8.4PYSEC-2026-3072
Ubuntu:22.04:LTSsoupsieveno fix listedUBUNTU-CVE-2026-49477
Ubuntu:24.04:LTSsoupsieveno fix listedUBUNTU-CVE-2026-49477
Ubuntu:26.04:LTSsoupsieveno fix listedUBUNTU-CVE-2026-49477
Ubuntu:26.10soupsieveno fix listedUBUNTU-CVE-2026-49477

Affected products (as reported)

VendorProductVersions
facelessuser soupsieve < 2.8.4

Weakness: CWE-400, CWE-1333 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

References