Vulnerability · Published Jun 30, 2026 · Assigned by apache

CVE-2026-49432Apache ActiveMQ, Apache ActiveMQ All, Apache ActiveMQ Stomp: STOMP negative content-length enables denial of service

High 7.5

In plain English

A high-severity improper input validation in Apache ActiveMQ from Apache Software Foundation. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.8% (higher than 56% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)7.5High
Exploit odds (30 days)0.8%top 43.7% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

Improper Input Validation vulnerability in Apache ActiveMQ, Apache ActiveMQ All, Apache ActiveMQ Stomp. A remote unauthenticated peer that can reach an exposed STOMP connector can trigger denial-of-service behavior by sending a negative content-length. For the NIO STOMP transport, an attacker can keep streaming body bytes and grow the per-connection command buffer beyond configured limits to cause OOM. For the blocking STOMP protocol, an error will instead force abnormal transport exception handling for the affected connection and closure. This issue affects Apache ActiveMQ: before 5.19.8, from 6.0.0 before 6.2.7; Apache ActiveMQ All: before 5.19.8, from 6.0.0 before 6.2.7; Apache ActiveMQ Stomp: before 5.19.8, from 6.0.0 before 6.2.7. Users are recommended to upgrade to version 6.2.7 or 5.19.8, which fixes the issue.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Debian:12activemqno fix listedDEBIAN-CVE-2026-49432
Debian:13activemqno fix listedDEBIAN-CVE-2026-49432
Mavenorg.apache.activemq:activemq-all5.19.8GHSA-xjwq-9jw5-jf7w
Mavenorg.apache.activemq:activemq-all6.2.7GHSA-xjwq-9jw5-jf7w
Mavenorg.apache.activemq:activemq-stomp5.19.8GHSA-xjwq-9jw5-jf7w
Mavenorg.apache.activemq:activemq-stomp6.2.7GHSA-xjwq-9jw5-jf7w
Mavenorg.apache.activemq:apache-activemq5.19.8GHSA-xjwq-9jw5-jf7w
Mavenorg.apache.activemq:apache-activemq6.2.7GHSA-xjwq-9jw5-jf7w
Ubuntu:24.04:LTSactivemqno fix listedUBUNTU-CVE-2026-49432
Ubuntu:25.10activemqno fix listedUBUNTU-CVE-2026-49432
Ubuntu:26.04:LTSactivemqno fix listedUBUNTU-CVE-2026-49432
Ubuntu:26.10activemqno fix listedUBUNTU-CVE-2026-49432

Affected products (as reported)

VendorProductVersions
Apache Software Foundation Apache ActiveMQ 0 – before 5.19.86.0.0 – before 6.2.7
Apache Software Foundation Apache ActiveMQ All 0 – before 5.19.86.0.0 – before 6.2.7
Apache Software Foundation Apache ActiveMQ Stomp 0 – before 5.19.86.0.0 – before 6.2.7

Weakness: CWE-20 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

References