Vulnerability · Published Aug 21, 2026 · Assigned by GitHub_M
CVE-2026-49360Recce server has unauthenticated SQL execution that allows local file read/write through DuckDB
High 7.8
In plain English
A high-severity security flaw in recce from DataRecce. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 1.1% (higher than 65% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
Recce is a data-validation toolkit for enhanced dbt (data build tool) PR review. Prior to version 1.50.0, OSS server deployments that expose the server to an untrusted network without authentication are vulnerable to unauthenticated SQL execution through the query run API. When Recce is configured with a DuckDB-backed project, an attacker can use DuckDB filesystem primitives to read and write files accessible to the Recce server process. The impact depends on how Recce is deployed, but may include disclosure of local files, tampering with Recce/dbt artifacts, modification of browser-served static files leading to stored XSS, and modification of application files if those paths are writable. If Recce is run as root, file access occurs with root privileges inside that host or container. This issue has been patched in Recce `v1.50.0`. Users should upgrade to Recce `v1.50.0` or later. The patch restricts unsafe file read/write behavior for DuckDB-backed query execution and hardens the affected query path. Other warehouse adapters have also been reviewed for similar exposure. Users who cannot upgrade immediately should avoid exposing `recce server` to the public internet or any untrusted network. Recommended mitigations include enabling authentication or placing Recce behind an authenticated reverse proxy/VPN, running Recce as a non-root user, using a read-only application filesystem where possible, and ensuring that sensitive files or credentials are not available to the Recce process.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| PyPI | recce | 1.50.0 | GHSA-rh62-j648-g5qc |
| PyPI | recce | 1.50.0 | PYSEC-2026-3049 |
Affected products (as reported)
Weakness: CWE-73 · Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:L/VI:L/VA:L/SC:L/SI:H/SA:N
References
- https://github.com/DataRecce/recce/security/advisories/GHSA-rh62-j648-g5qc x_refsource_CONFIRM
- https://github.com/DataRecce/recce/releases/tag/v1.50.0 x_refsource_MISC
- https://github.com/pypa/advisory-database/tree/main/vulns/recce/PYSEC-2026-3049.yaml x_refsource_MISC