Vulnerability · Published Jul 9, 2026 · Assigned by GitHub_M

CVE-2026-49276Kirby: Self cross-site scripting (self-XSS) in the writer field

High 7.4

In plain English

A high-severity security flaw in kirby from getkirby. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.4% (higher than 38% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 4.0)7.4High
Exploit odds (30 days)0.4%top 62.3% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

Kirby is an open-source content management system. Prior to 4.9.4 and 5.4.4, Kirby sites using the writer field in any blueprint allowed a scripting link to be included as the target of a link or email link in writer mark components, making the target clickable by the user who entered it and enabling self cross-site scripting in the Panel. This issue is fixed in versions 4.9.4 and 5.4.4.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Packagistgetkirby/cms4.9.4GHSA-rhj6-r49h-5932
Packagistgetkirby/cms5.4.4GHSA-rhj6-r49h-5932

Affected products (as reported)

VendorProductVersions
getkirby kirby < 4.9.4>= 5.0.0, < 5.4.4

Weakness: CWE-83 · Vector: CVSS:4.0/AV:N/AC:H/AT:N/PR:N/UI:A/VC:H/VI:H/VA:N/SC:N/SI:N/SA:N

References