Vulnerability · Published Oct 13, 2026 · Assigned by GitHub_M

CVE-2026-49265OAuthLib: Timing Attack Vulnerability in PKCE code_verifier Comparison

Medium 6.8

In plain English

A medium-severity security flaw in oauthlib from oauthlib. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.2% (higher than 15% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)6.8Medium
Exploit odds (30 days)0.2%top 84.5% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

OAuthLib is an implementation of the OAuth request-signing logic for Python 3.6+. From 3.0.0 until 4.0.0, OAuthLib's PKCE checks in oauthlib/oauth2/rfc6749/grant_types/authorization_code.py compare attacker-supplied code_verifier values with stored challenges using ordinary string equality in code_challenge_method_plain and code_challenge_method_s256. Because the comparison can return after a length difference or the first mismatching character, repeated token endpoint measurements can reveal common-prefix timing information that could potentially allow recovery of the code_verifier, unauthorized access-token acquisition, and account takeover. Practical exploitation requires an intercepted, single-use authorization code and enough measurements to overcome real-world network noise; the local timing benchmark does not establish practical remote account takeover, so the weakness remains a defense-in-depth concern. This issue is fixed in version 4.0.0.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Debian:12python-oauthlibno fix listedDEBIAN-CVE-2026-49265
Debian:13python-oauthlibno fix listedDEBIAN-CVE-2026-49265
Debian:14python-oauthlibno fix listedDEBIAN-CVE-2026-49265
PyPIoauthlib4.0.0GHSA-xpv3-w29h-x7cv
PyPIoauthlib4.0.0PYSEC-2026-4114
Ubuntu:22.04:LTSpython-oauthlibno fix listedUBUNTU-CVE-2026-49265
Ubuntu:24.04:LTSpython-oauthlibno fix listedUBUNTU-CVE-2026-49265
Ubuntu:26.04:LTSpython-oauthlibno fix listedUBUNTU-CVE-2026-49265
Ubuntu:26.10python-oauthlibno fix listedUBUNTU-CVE-2026-49265

Affected products (as reported)

VendorProductVersions
oauthlib oauthlib >= 3.0.0, < 4.0.0

Weakness: CWE-208 · Vector: CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:H/I:H/A:N

References