Vulnerability · Published Jun 17, 2026 · Assigned by GitHub_M

CVE-2026-48979PHP Standard Library: HTTP/2 server-side missing content-length validation enables request smuggling

High 7.5

In plain English

A high-severity security flaw in php-standard-library from php-standard-library. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.3% (higher than 19% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)7.5High
Exploit odds (30 days)0.3%top 81.1% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

PHP Standard Library (PSL) is set of APIs covering async, collections, networking, I/O, cryptography, terminal UI, etc. In versions 6.1.0, 6.1.1 and 6.2.0, the Psl\H2\ServerConnection does not validate that the total bytes received in DATA frames match the content-length header declared in the HEADERS frame, allowing request smuggling. This is in violation of RFC 9113 §8.1.1. A malicious client is able to send more DATA bytes than declared, smuggling additional content past application-level size limits and send fewer DATA bytes than declared and close the stream early, causing applications that trust the declared length to behave incorrectly. The vulnerability is only reachable for consumers using Psl\H2\ServerConnection directly to accept untrusted client traffic. Consumers of documented high-level PSL APIs are not affected. This issue has been fixed in versions 6.1.2 and 6.2.1.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Packagistphp-standard-library/h26.1.2GHSA-pw9p-jvrm-f7rm
Packagistphp-standard-library/h26.2.1GHSA-pw9p-jvrm-f7rm
Packagistphp-standard-library/php-standard-library6.1.2GHSA-pw9p-jvrm-f7rm
Packagistphp-standard-library/php-standard-library6.2.1GHSA-pw9p-jvrm-f7rm
Ubuntu:22.04:LTSphp8.1no fix listedUBUNTU-CVE-2026-48979
Ubuntu:24.04:LTSphp8.3no fix listedUBUNTU-CVE-2026-48979
Ubuntu:25.10php8.4no fix listedUBUNTU-CVE-2026-48979
Ubuntu:26.04:LTSphp8.5no fix listedUBUNTU-CVE-2026-48979

Affected products (as reported)

VendorProductVersions
php-standard-library php-standard-library >= 6.1.0, < 6.1.2>= 6.2.0, < 6.2.1
php-standard-library php-standard-library/h2 >= 6.1.0, < 6.1.2>= 6.2.0, < 6.2.1

Weakness: CWE-444 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N

References