Vulnerability · Published Sep 17, 2026 · Assigned by GitHub_M

CVE-2026-48977OpenSlide: Arbitrary memory write with crafted Ventana BIF file

High 7.7

In plain English

A high-severity security flaw in openslide from openslide. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.5% (higher than 41% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 4.0)7.7High
Exploit odds (30 days)0.5%top 58.7% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

OpenSlide is a C library for reading whole slide image files. From 3.4.1 until 4.0.1, OpenSlide's parse_level0_xml() processing in src/openslide-vendor-ventana.c accepts nonpositive row or column tile counts from a crafted Ventana BIF file. The invalid counts produce attacker-controlled relative memory offsets and allow arbitrary values to be written at those offsets, affecting all supported platforms and configurations and resulting in a crash or potential arbitrary code execution. This issue is fixed in version 4.0.1.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Debian:12openslide3.4.1+dfsg-6+deb12u1DEBIAN-CVE-2026-48977
Debian:13openslide3.4.1+dfsg-7+deb13u1DEBIAN-CVE-2026-48977
Debian:14openslide3.4.1+dfsg-9DEBIAN-CVE-2026-48977
Ubuntu:22.04:LTSopenslideno fix listedUBUNTU-CVE-2026-48977
Ubuntu:24.04:LTSopenslideno fix listedUBUNTU-CVE-2026-48977
Ubuntu:25.10openslideno fix listedUBUNTU-CVE-2026-48977
Ubuntu:26.04:LTSopenslideno fix listedUBUNTU-CVE-2026-48977
Ubuntu:26.10openslideno fix listedUBUNTU-CVE-2026-48977

Affected products (as reported)

VendorProductVersions
openslide openslide >= 3.4.1, < 4.0.1

Weakness: CWE-123, CWE-823, CWE-1284 · Vector: CVSS:4.0/AV:N/AC:H/AT:N/PR:L/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N

References