Vulnerability · Published Jun 17, 2026 · Assigned by GitHub_M

CVE-2026-48817Starlette: Arbitrary HTTP method dispatched to `HTTPEndpoint` attributes via `getattr`

Medium 5.3

In plain English

A medium-severity security flaw in starlette from Kludex. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.2% (higher than 12% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)5.3Medium
Exploit odds (30 days)0.2%top 88.3% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

Starlette is a lightweight ASGI framework/toolkit. In versions 1.0.1 and below, when dispatching a request, HTTPEndpoint selects the handler by lowercasing the HTTP method and looking it up as an attribute with getattr, without restricting the lookup to a known set of HTTP verbs. When an HTTPEndpoint subclass is registered through Route(...) without an explicit methods= argument, the route does not constrain the method and every method reaches the endpoint. If a non-standard HTTP method whose lowercased name matches an attribute on the endpoint subclass reaches the endpoint, that attribute is invoked as if it were a request handler. An attacker can use this to reach methods that were never meant to be HTTP handlers, such as internal helpers, without the authorization checks applied by the intended public handler. An application (including Starlette-based frameworks like FastAPI) is affected if it registers an HTTPEndpoint subclass via Route(...) without explicitly setting methods=, and that subclass includes extra methods named like non-standard HTTP verbs that take one request argument and return a response. This issue has been fixed in version 1.1.0.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Debian:12starlette0.26.1-1+deb12u2DEBIAN-CVE-2026-48817
Debian:13starlette0.46.1-3+deb13u3DEBIAN-CVE-2026-48817
Debian:14starlette1.1.0-1DEBIAN-CVE-2026-48817
PyPIstarlette1.1.0GHSA-x746-7m8f-x49c
PyPIstarlette1.1.0PYSEC-2026-2280
Ubuntu:22.04:LTSstarletteno fix listedUBUNTU-CVE-2026-48817
Ubuntu:24.04:LTSstarletteno fix listedUBUNTU-CVE-2026-48817
Ubuntu:25.10starletteno fix listedUBUNTU-CVE-2026-48817
Ubuntu:26.04:LTSstarletteno fix listedUBUNTU-CVE-2026-48817
Ubuntu:26.10starletteno fix listedUBUNTU-CVE-2026-48817

Affected products (as reported)

VendorProductVersions
Kludex starlette < 1.1.0

Weakness: CWE-470 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:N

References