Vulnerability · Published Jul 14, 2026 · Assigned by GitHub_M

CVE-2026-48807Twig: Sandbox `__toString()` policy bypass via `Traversable` in `join` and `replace` filters

High 7.1

In plain English

A high-severity incorrect authorization in Twig from twigphp. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.4% (higher than 31% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 4.0)7.1High
Exploit odds (30 days)0.4%top 69.3% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

Twig is a template language for PHP. Prior to 3.27.0, the sandbox __toString() checks do not fully cover Traversable values passed to join and replace filters or operands evaluated by the in and not in operators, allowing contained Stringable objects to be coerced to strings without consulting the sandbox policy. This issue is fixed in version 3.27.0.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Debian:14php-twig3.27.0-1DEBIAN-CVE-2026-48807
Packagisttwig/twig3.27.0GHSA-8x9c-rmqh-456c
Ubuntu:25.10php-twigno fix listedUBUNTU-CVE-2026-48807
Ubuntu:26.10php-twigno fix listedUBUNTU-CVE-2026-48807

Affected products (as reported)

VendorProductVersions
twigphp Twig < 3.27.0

Weakness: CWE-693, CWE-863 · Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:L/VA:N/SC:N/SI:N/SA:N

References