Vulnerability · Published Jun 19, 2026 · Assigned by GitHub_M
CVE-2026-48773ProxySQL pre-auth heap overflow in MySQL and PostgreSQL first-packet handling
Critical 9.8
In plain English
A critical-severity out-of-bounds write in proxysql from sysown. Proof-of-concept exploit code is public. The chance it is exploited in the next 30 days is estimated at 0.7% (higher than 53% of all known vulnerabilities).
Official description
ProxySQL is a proxy for MySQL and its forks, as well as PostgreSQL. Versions 2.0.18 through 3.0.8 have a pre-authentication heap memory corruption vulnerability in the MySQL and PostgreSQL protocol first-read paths. A remote unauthenticated client can declare an oversized first packet length, and ProxySQL passes that attacker-controlled length directly to `recv()` while writing into a fixed 32 KB input queue. Version 3.0.9 patches the issue.
Affected products (as reported)
Weakness: CWE-787 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
References
- https://github.com/sysown/proxysql/security/advisories/GHSA-58ww-865x-grpr x_refsource_CONFIRM
- https://github.com/sysown/proxysql/releases/tag/v3.0.9 x_refsource_MISC