Vulnerability · Published Jun 22, 2026 · Assigned by GitHub_M

CVE-2026-48746vLLM: OpenAI auth bypass

Critical 9.1

In plain English

A critical-severity security flaw in vllm from vllm-project. Proof-of-concept exploit code is public. The chance it is exploited in the next 30 days is estimated at 1.2% (higher than 67% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)9.1Critical
Exploit odds (30 days)1.2%top 32.9% of all CVEs
Exploited in the wildNo reportsCISA SSVC: poc
Attack toolingNoneno public tooling known

Official description

vLLM is an inference and serving engine for large language models (LLMs). From 0.3.0 until 0.22.0, a vulnerability in ASGI web servers and starlette's trust on those web servers enables an authentication bypass of the OpenAI API AuthenticationMiddleware. It allows to use the API without providing the configured VLLM_API_KEY or --api-key. This vulnerability is fixed in 0.22.0.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
PyPIvllm0.22.0GHSA-94f4-hr76-p5j6
PyPIvllm0.22.0PYSEC-2026-226

Affected products (as reported)

VendorProductVersions
vllm-project vllm >= 0.3.0, < 0.22.0

Weakness: CWE-444, CWE-501 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:H

References