Vulnerability · Published Jul 27, 2026 · Assigned by apache
CVE-2026-48145Apache Thrift: C++ TSSLSocket matchName() RFC 6125 Wildcard Bypass
High 8.2
In plain English
A high-severity security flaw in Apache Thrift from Apache Software Foundation. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.4% (higher than 36% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Severity (CVSS 4.0)8.2High
Exploit odds (30 days)0.4%top 63.7% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known
Official description
Improper Validation of Certificate with Host Mismatch vulnerability in Apache Thrift C++ bindings. This issue affects Apache Thrift: before 0.24.0. Users are recommended to upgrade to version 0.24.0, which fixes the issue.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| Debian:12 | thrift | no fix listed | DEBIAN-CVE-2026-48145 |
| Debian:13 | thrift | no fix listed | DEBIAN-CVE-2026-48145 |
| Debian:14 | thrift | 0.24.0-2 | DEBIAN-CVE-2026-48145 |
| Ubuntu:22.04:LTS | thrift | no fix listed | UBUNTU-CVE-2026-48145 |
| Ubuntu:24.04:LTS | thrift | no fix listed | UBUNTU-CVE-2026-48145 |
| Ubuntu:26.04:LTS | thrift | no fix listed | UBUNTU-CVE-2026-48145 |
| Ubuntu:26.10 | thrift | no fix listed | UBUNTU-CVE-2026-48145 |
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| Apache Software Foundation | Apache Thrift | 0 – before 0.24.0 |
Weakness: CWE-297 · Vector: CVSS:4.0/AV:N/AC:H/AT:N/PR:N/UI:N/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N