Vulnerability · Published Jul 24, 2026 · Assigned by GitHub_M

CVE-2026-48032Hulumi: IAM-role policy checks bypassed when the role trusts multiple OIDC providers

High 8.3

In plain English

A high-severity security flaw in hulumi from kerberosmansour. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.5% (higher than 45% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 4.0)8.3High
Exploit odds (30 days)0.5%top 54.5% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

Hulumi is an open-source toolkit that ships secure-by-default cloud and platform infrastructure components for Pulumi. Prior to version 1.4.0, IAM-role policy checks can be bypassed when the role trusts multiple OIDC providers. This issue has been patched in version 1.4.0.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
npm@hulumi/policies1.4.0GHSA-g759-4pxw-6692

Affected products (as reported)

VendorProductVersions
kerberosmansour hulumi < 1.4.0

Weakness: CWE-697 · Vector: CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:N/VI:H/VA:L/SC:N/SI:N/SA:N

References