Vulnerability · Published May 28, 2026 · Assigned by GitHub_M
CVE-2026-47759TinyMCE Cross-Site Scripting (XSS) vulnerability using through data-mce- prefixed src, href, style attributes
High 8.7
In plain English
A high-severity cross-site scripting in tinymce from tinymce. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.3% (higher than 21% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
TinyMCE is an open source rich text editor. Prior to 5.11.1, 7.9.3, and 8.5.1, there is a stored XSS vulnerability via unsanitized data-mce-* attributes (data-mce-href, data-mce-src, data-mce-style). Allows attackers to inject malicious values that override safe attributes during serialization, bypassing validation. This vulnerability is fixed in 5.11.1, 7.9.3, and 8.5.1.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| NuGet | tinymce | no fix listed | GHSA-q742-qvgc-gc2f |
| NuGet | tinymce | 8.5.1 | GHSA-q742-qvgc-gc2f |
| NuGet | tinymce | 7.9.3 | GHSA-q742-qvgc-gc2f |
| Packagist | tinymce/tinymce | 8.5.1 | GHSA-q742-qvgc-gc2f |
| Packagist | tinymce/tinymce | no fix listed | GHSA-q742-qvgc-gc2f |
| Packagist | tinymce/tinymce | 7.9.3 | GHSA-q742-qvgc-gc2f |
| npm | tinymce | no fix listed | GHSA-q742-qvgc-gc2f |
| npm | tinymce | 8.5.1 | GHSA-q742-qvgc-gc2f |
| npm | tinymce | 7.9.3 | GHSA-q742-qvgc-gc2f |
Affected products (as reported)
Weakness: CWE-79 · Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:H/I:H/A:N
References
- https://github.com/tinymce/tinymce/security/advisories/GHSA-q742-qvgc-gc2f x_refsource_CONFIRM
- https://www.tiny.cloud/docs/tinymce/7/7.9.3-release-notes/#overview x_refsource_MISC
- https://www.tiny.cloud/docs/tinymce/8/8.5.1-release-notes/#overview x_refsource_MISC