Vulnerability · Published Jun 11, 2026 · Assigned by GitHub_M
CVE-2026-47181PenguinMod-BackendApi: NoSQL Injection in Password Reset Endpoint Allows Account Takeover
High 8.7
In plain English
A high-severity improper input validation in PenguinMod-BackendApi from PenguinMod. Proof-of-concept exploit code is public. The chance it is exploited in the next 30 days is estimated at 0.3% (higher than 24% of all known vulnerabilities).
Official description
PenguinMod-BackendApi is the backend api for penguinmod. Prior to version 1.0.0, a NoSQL injection vulnerability in the password reset endpoint allows any authenticated user to change the password of an account, leading to full account takeover. An attacker only needs a registered account and a valid password reset token for their own account. This issue has been patched in version 1.0.0.
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| PenguinMod | PenguinMod-BackendApi | < 1.0.0 |
Weakness: CWE-20, CWE-943 · Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:L/SC:N/SI:N/SA:N