Vulnerability · Published Jul 1, 2026 · Assigned by GitHub_M
CVE-2026-46680containerd user ID handling bypass allows runAsNonRoot evasion
High 7.3
In plain English
A high-severity privilege mismanagement in containerd from containerd. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.2% (higher than 6% of all known vulnerabilities). Ready-made attack tooling exists: public proof-of-concept code. Fixed versions are available - upgrade the affected package.
Official description
containerd is an open-source container runtime. In versions prior to 1.7.32, 2.0.9, 2.2.4 and 2.3.1, containers launched with a numeric User directive that cannot be parsed as a 32-bit integer are incorrectly treated as a username, leading to runAsNonRoot evasion. If a crafted image provides an /etc/passwd file mapping this large numeric string to root, the container ultimately runs as root (UID 0). This allows the Kubernetes runAsNonRoot restriction to be bypassed, causing unexpected behavior for environments that require containers to run as a non-root user. This issue has been fixed in versions 1.7.32, 2.0.9, 2.2.4 and 2.3.1.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| Alpine:v3.24 | containerd | 2.3.1-r0 | ALPINE-CVE-2026-46680 |
| Debian:12 | containerd | no fix listed | DEBIAN-CVE-2026-46680 |
| Debian:13 | containerd | no fix listed | DEBIAN-CVE-2026-46680 |
| Debian:14 | containerd | 2.1.9+ds1-1 | DEBIAN-CVE-2026-46680 |
| Go | github.com/containerd/containerd | 1.7.32 | GO-2026-5378 |
| Go | github.com/containerd/containerd | 1.7.32 | GHSA-fqw6-gf59-qr4w |
| Go | github.com/containerd/containerd/v2 | 2.3.1 | GHSA-fqw6-gf59-qr4w |
| Go | github.com/containerd/containerd/v2 | 2.0.9, 2.2.4, 2.3.1 | GO-2026-5378 |
| Go | github.com/containerd/containerd/v2 | 2.2.4 | GHSA-fqw6-gf59-qr4w |
| Go | github.com/containerd/containerd/v2 | 2.0.9 | GHSA-fqw6-gf59-qr4w |
| Ubuntu:22.04:LTS | containerd | no fix listed | UBUNTU-CVE-2026-46680 |
| Ubuntu:25.10 | containerd | no fix listed | UBUNTU-CVE-2026-46680 |
| Ubuntu:26.10 | containerd | no fix listed | UBUNTU-CVE-2026-46680 |
| Ubuntu:24.04:LTS | containerd-app | no fix listed | UBUNTU-CVE-2026-46680 |
| Ubuntu:25.10 | containerd-app | no fix listed | UBUNTU-CVE-2026-46680 |
| Ubuntu:26.04:LTS | containerd-app | no fix listed | UBUNTU-CVE-2026-46680 |
| Ubuntu:26.10 | containerd-app | no fix listed | UBUNTU-CVE-2026-46680 |
| Ubuntu:25.10 | containerd-stable | no fix listed | UBUNTU-CVE-2026-46680 |
| Ubuntu:26.04:LTS | containerd-stable | no fix listed | UBUNTU-CVE-2026-46680 |
| Ubuntu:26.10 | containerd-stable | no fix listed | UBUNTU-CVE-2026-46680 |
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| containerd | containerd | < 1.7.32>= 2.0.4, < 2.0.9>= 2.0.10, < 2.2.4>= 2.2.5, < 2.3.1 |
Weakness: CWE-269 · Vector: CVSS:4.0/AV:L/AC:L/AT:P/PR:N/UI:P/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N
References
- https://github.com/containerd/containerd/security/advisories/GHSA-fqw6-gf59-qr4w x_refsource_CONFIRM