Vulnerability · Published Jul 14, 2026 · Assigned by GitHub_M
CVE-2026-46644symfony/polyfill-intl-idn accepts xn-- labels whose Punycode payload decodes to ASCII-only: insecure equivalence
Medium 6.9
In plain English
A medium-severity security flaw in polyfill from symfony. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.5% (higher than 45% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
Symfony Polyfill backports PHP features and provides compatibility layers for extensions and functions. From 1.17.1 until 1.38.1, symfony/polyfill-intl-idn accepts xn-- labels whose Punycode payload is empty or decodes to ASCII-only code points because Idn::process() does not enforce the UTS #46 revision 33 requirement that decoded ACE labels contain at least one non-ASCII code point. Originally unequal domain names can be regarded as equal, which can lead to blacklist bypassing, inconsistent URL parsing, and server-side request forgery in applications using the polyfill to canonicalise or compare hostnames. This issue is fixed in version 1.38.1.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| Debian:12 | php-symfony-polyfill | no fix listed | DEBIAN-CVE-2026-46644 |
| Debian:14 | php-symfony-polyfill | 1.38.1-1 | DEBIAN-CVE-2026-46644 |
| Packagist | symfony/polyfill | 1.38.1 | GHSA-2xf4-cg6j-vhgq |
| Packagist | symfony/polyfill-intl-idn | 1.38.1 | GHSA-2xf4-cg6j-vhgq |
| Ubuntu:22.04:LTS | php-symfony-polyfill | no fix listed | UBUNTU-CVE-2026-46644 |
| Ubuntu:24.04:LTS | php-symfony-polyfill | no fix listed | UBUNTU-CVE-2026-46644 |
| Ubuntu:25.10 | php-symfony-polyfill | no fix listed | UBUNTU-CVE-2026-46644 |
| Ubuntu:26.04:LTS | php-symfony-polyfill | no fix listed | UBUNTU-CVE-2026-46644 |
| Ubuntu:26.10 | php-symfony-polyfill | no fix listed | UBUNTU-CVE-2026-46644 |
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| symfony | polyfill | >= 1.17.1, < 1.38.1 |
| symfony | polyfill-intl-idn | >= 1.17.1, < 1.38.1 |
Weakness: CWE-1289 · Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:L/VA:N/SC:L/SI:L/SA:N
References
- https://github.com/symfony/polyfill/security/advisories/GHSA-2xf4-cg6j-vhgq x_refsource_CONFIRM
- https://github.com/symfony/polyfill/commit/1be936e2491ccebe152bd736dfc91eb1422c8bec x_refsource_MISC
- https://github.com/symfony/polyfill/releases/tag/v1.38.1 x_refsource_MISC