Vulnerability · Published May 15, 2026 · Assigned by GitHub_M

CVE-2026-46483Vim: Command injection in tar#Vimuntar via missing shellescape {special} flag

Low 3.6

In plain English

A low-severity OS command injection in vim from vim. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.6% (higher than 46% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)3.6Low
Exploit odds (30 days)0.6%top 53.7% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

Vim is an open source, command line text editor. Prior to 9.2.0479, a command injection vulnerability exists in tar#Vimuntar() in runtime/autoload/tar.vim when decompressing .tgz archives on Unix-like systems. The function builds :!gunzip and :!gzip -d commands using shellescape(tartail) without the {special} flag, allowing a crafted archive filename to trigger Vim cmdline-special expansion and execute shell commands in the user's context. This vulnerability is fixed in 9.2.0479.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
AlmaLinux:10vim-X112:9.1.083-9.el10_2.7ALSA-2026:38509
AlmaLinux:8vim-X112:8.0.1763-27.el8_10ALSA-2026:38510
AlmaLinux:9vim-X112:8.2.2637-26.el9_8.10ALSA-2026:38511
AlmaLinux:10vim-common2:9.1.083-9.el10_2.7ALSA-2026:38509
AlmaLinux:8vim-common2:8.0.1763-27.el8_10ALSA-2026:38510
AlmaLinux:9vim-common2:8.2.2637-26.el9_8.10ALSA-2026:38511
AlmaLinux:10vim-data2:9.1.083-9.el10_2.7ALSA-2026:38509
AlmaLinux:10vim-enhanced2:9.1.083-9.el10_2.7ALSA-2026:38509
AlmaLinux:8vim-enhanced2:8.0.1763-27.el8_10ALSA-2026:38510
AlmaLinux:9vim-enhanced2:8.2.2637-26.el9_8.10ALSA-2026:38511
AlmaLinux:10vim-filesystem2:9.1.083-9.el10_2.7ALSA-2026:38509
AlmaLinux:8vim-filesystem2:8.0.1763-27.el8_10ALSA-2026:38510
AlmaLinux:9vim-filesystem2:8.2.2637-26.el9_8.10ALSA-2026:38511
AlmaLinux:10vim-minimal2:9.1.083-9.el10_2.7ALSA-2026:38509
AlmaLinux:8vim-minimal2:8.0.1763-27.el8_10ALSA-2026:38510
AlmaLinux:9vim-minimal2:8.2.2637-26.el9_8.10ALSA-2026:38511
AlmaLinux:10xxd2:9.1.083-9.el10_2.7ALSA-2026:38509
Alpine:v3.23vim9.2.0481-r0ALPINE-CVE-2026-46483
Alpine:v3.24vim9.2.0481-r0ALPINE-CVE-2026-46483
Debian:12vimno fix listedDEBIAN-CVE-2026-46483
Debian:13vim2:9.1.1230-2+deb13u1DEBIAN-CVE-2026-46483
Debian:14vim2:9.2.0524-1DEBIAN-CVE-2026-46483
Rocky Linux:10vim2:9.1.083-9.el10_2.7RLSA-2026:38509
Rocky Linux:8vim2:8.0.1763-27.el8_10RLSA-2026:38510
Rocky Linux:9vim2:8.2.2637-26.el9_8.10RLSA-2026:38511
Ubuntu:22.04:LTSvim2:8.2.3995-1ubuntu2.31UBUNTU-CVE-2026-46483
Ubuntu:24.04:LTSvim2:9.1.0016-1ubuntu7.15UBUNTU-CVE-2026-46483
Ubuntu:25.10vim2:9.1.0967-1ubuntu6.6UBUNTU-CVE-2026-46483
Ubuntu:26.04:LTSvim2:9.1.2141-1ubuntu4.3UBUNTU-CVE-2026-46483

Affected products (as reported)

VendorProductVersions
vim vim < 9.2.479

Weakness: CWE-78, CWE-88 · Vector: CVSS:3.1/AV:L/AC:H/PR:N/UI:R/S:U/C:L/I:L/A:N

References