Vulnerability · Published Jun 8, 2026 · Assigned by GitHub_M

CVE-2026-46477Flowise: Dataset create+update mass-assignment allows cross-workspace dataset takeover

High 7.7

In plain English

A high-severity security flaw in Flowise from FlowiseAI. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.3% (higher than 27% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 4.0)7.7High
Exploit odds (30 days)0.3%top 73.0% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

Flowise is a drag & drop user interface to build a customized large language model flow. Prior to version 3.1.2, dataset create and update mass-assignment allows cross-workspace dataset takeover. This issue has been patched in version 3.1.2.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
npmflowise3.1.2GHSA-5h9v-837x-m97r

Affected products (as reported)

VendorProductVersions
FlowiseAI Flowise < 3.1.2

Weakness: CWE-915 · Vector: CVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N

References