Vulnerability · Published Jun 8, 2026 · Assigned by GitHub_M
CVE-2026-46475Flowise: Assistant create+update mass-assignment allows cross-workspace assistant takeover
High 7.7
In plain English
A high-severity security flaw in Flowise from FlowiseAI. Proof-of-concept exploit code is public. The chance it is exploited in the next 30 days is estimated at 0.3% (higher than 27% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Severity (CVSS 4.0)7.7High
Exploit odds (30 days)0.3%top 73.0% of all CVEs
Exploited in the wildNo reportsCISA SSVC: poc
Attack toolingNoneno public tooling known
Official description
Flowise is a drag & drop user interface to build a customized large language model flow. Prior to version 3.1.2, assistant create and update mass-assignment allows cross-workspace assistant takeover. This issue has been patched in version 3.1.2.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| npm | flowise | 3.1.2 | GHSA-78pr-c5x5-jggc |
Affected products (as reported)
Weakness: CWE-915 · Vector: CVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N
References
- https://github.com/FlowiseAI/Flowise/security/advisories/GHSA-78pr-c5x5-jggc x_refsource_CONFIRM
- https://github.com/FlowiseAI/Flowise/releases/tag/flowise%403.1.2 x_refsource_MISC