Vulnerability · Published Jun 8, 2026 · Assigned by GitHub_M
CVE-2026-46440Flowise: Basic Auth Credentials Exposed via API
High 7.5
In plain English
A high-severity security flaw in Flowise from FlowiseAI. Proof-of-concept exploit code is public. The chance it is exploited in the next 30 days is estimated at 0.2% (higher than 14% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Severity (CVSS 3.0)7.5High
Exploit odds (30 days)0.2%top 86.0% of all CVEs
Exploited in the wildNo reportsCISA SSVC: poc
Attack toolingNoneno public tooling known
Official description
Flowise is a drag & drop user interface to build a customized large language model flow. Prior to version 3.1.2, the checkBasicAuth endpoint validates credentials in plaintext without rate limiting and with direct comparison. This issue has been patched in version 3.1.2.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| npm | flowise | 3.1.2 | GHSA-php6-83fg-gw3g |
Affected products (as reported)
Weakness: CWE-522 · Vector: CVSS:3.0/AV:N/AC:H/PR:N/UI:R/S:U/C:H/I:H/A:H
References
- https://github.com/FlowiseAI/Flowise/security/advisories/GHSA-php6-83fg-gw3g x_refsource_CONFIRM
- https://github.com/FlowiseAI/Flowise/releases/tag/flowise%403.1.2 x_refsource_MISC