Vulnerability · Published Jul 17, 2026 · Assigned by GitHub_M
CVE-2026-46420setup-php: Command Injection in Repository-Derived PHP Version Resolution
Medium 5.6
In plain English
A medium-severity OS command injection in setup-php from shivammathur. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 2.0% (higher than 81% of all known vulnerabilities). Ready-made attack tooling exists: public proof-of-concept code.
Official description
setup-php is a GitHub action to set up PHP with extensions, php.ini configuration, coverage drivers, and tools. From 2.25.0 prior to 2.37.1, shivammathur/setup-php resolves the PHP version from repository-controlled files such as .php-version, composer.lock through platform-overrides.php, and composer.json through config.platform.php, and insufficiently constrains those values before incorporating them into generated shell or PowerShell setup scripts, allowing command injection on a GitHub Actions runner when workflows such as pull_request_target check out attacker-controlled contents before invoking setup-php. This issue is fixed in version 2.37.1.
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| shivammathur | setup-php | >= 2.25.0, < 2.37.1 |
Weakness: CWE-78 · Vector: CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:L/A:L