Vulnerability · Published Jun 5, 2026 · Assigned by GitHub_M

CVE-2026-45758Malicious code in guardrails-ai 0.10.1 (supply chain compromise)

Critical 9.6

In plain English

A critical-severity security flaw in guardrails from guardrails-ai. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.3% (higher than 20% of all known vulnerabilities).

Severity (CVSS 3.1)9.6Critical
Exploit odds (30 days)0.3%top 79.9% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

Guardrails AI is a Python framework that helps build AI applications. On May 11, 2026 at approximately 6:00 PM Pacific, an attacker published a malicious version of `guardrails-ai` (0.10.1) to PyPI. Aany user who installed `guardrails-ai==0.10.1` from PyPI on May 11, 2026 may be affected. Security researchers identified the malicious package within approximately 2 hours of publication, and PyPI quarantined the repository. Based on our telemetry, Guardrails AI maintainers have observed no requests to Guardrails AI infrastructure originating from the malicious 0.10.1 version, and a review of system and access logs has produced no evidence of user data exfiltration through their systems. Users should upgrade to version 0.10.2 or downgrade to version 0.10.0, both of which are unaffected. Those who installed version 0.10.1 should rotate any credentials accessible from their machine (GitHub PATs, cloud provider keys, package registry tokens, API keys) and audit their GitHub account for unauthorized workflows or repositories.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
PyPIguardrails-aino fix listedGHSA-xmpw-2vmm-p4p6
PyPIguardrails-aino fix listedPYSEC-2026-206

Affected products (as reported)

VendorProductVersions
guardrails-ai guardrails = 0.10.1

Weakness: CWE-506 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:H/I:H/A:H

References