Vulnerability · Published Jul 14, 2026 · Assigned by GitHub_M

CVE-2026-45754Symfony: Mailjet Mailer Webhook Parser Never Verifies the Configured Secret — Unauthenticated Webhook Event Injection

Medium 6.9

In plain English

A medium-severity improper authentication in lox24-notifier from symfony. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.4% (higher than 39% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 4.0)6.9Medium
Exploit odds (30 days)0.4%top 61.1% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

Symfony is a PHP framework for web and console applications and a set of reusable PHP components. Prior to 6.4.40, 7.4.12, and 8.0.12, the Mailjet mailer bridge and LOX24 notifier bridge webhook parsers received configured webhook secrets but did not verify them, allowing unauthenticated POST requests to inject forged Mailjet and LOX24 event payloads. This issue is fixed in versions 6.4.40, 7.4.12, and 8.0.12.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Debian:13symfony6.4.41+dfsg-0+deb13u1DEBIAN-CVE-2026-45754
Debian:14symfony7.4.12+dfsg-1DEBIAN-CVE-2026-45754
Packagistsymfony/lox24-notifier7.4.12GHSA-64hg-93w9-fc35
Packagistsymfony/lox24-notifier8.0.12GHSA-64hg-93w9-fc35
Packagistsymfony/mailjet-mailer8.0.12GHSA-64hg-93w9-fc35
Packagistsymfony/mailjet-mailer6.4.40GHSA-64hg-93w9-fc35
Packagistsymfony/mailjet-mailer7.4.12GHSA-64hg-93w9-fc35
Packagistsymfony/symfony7.4.12GHSA-64hg-93w9-fc35
Packagistsymfony/symfony6.4.40GHSA-64hg-93w9-fc35
Packagistsymfony/symfony8.0.12GHSA-64hg-93w9-fc35
Ubuntu:25.10symfonyno fix listedUBUNTU-CVE-2026-45754
Ubuntu:26.04:LTSsymfonyno fix listedUBUNTU-CVE-2026-45754
Ubuntu:26.10symfonyno fix listedUBUNTU-CVE-2026-45754

Affected products (as reported)

VendorProductVersions
symfony symfony >= 6.4.0, < 6.4.40>= 7.0.0-BETA1, < 7.4.12>= 8.0.0-BETA1, < 8.0.12
symfony lox24-notifier >= 7.1.0-BETA1, < 7.4.12>= 8.0.0-BETA1, < 8.0.12
symfony mailjet-mailer >= 6.4.0, < 6.4.40>= 7.0.0-BETA1, < 7.4.12>= 8.0.0-BETA1, < 8.0.12

Weakness: CWE-287, CWE-306 · Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:L/VA:N/SC:N/SI:N/SA:N

References