Vulnerability · Published Jun 23, 2026 · Assigned by GitHub_M

CVE-2026-45692Caddy: Remote Admin Authorization Bypass in `/config` API via Array Index Normalization

Medium 5.4

In plain English

A medium-severity incorrect authorization in caddy from caddyserver. Proof-of-concept exploit code is public. The chance it is exploited in the next 30 days is estimated at 0.2% (higher than 15% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)5.4Medium
Exploit odds (30 days)0.2%top 84.7% of all CVEs
Exploited in the wildNo reportsCISA SSVC: poc
Attack toolingNoneno public tooling known

Official description

Caddy is an extensible server platform that uses TLS by default. From 2.4.0 until 2.11.3, the authorization layer and the /config traversal layer do not agree on what object the path refers to. In this case, a path authorized for one config object is accepted, but then resolves to a different config object during traversal. This happens because the authorization layer uses string prefix matching and the /config traversal layer parses array indices numerically using strconv.Atoi(). This vulnerability is fixed in 2.11.3.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Alpine:v3.23caddy2.11.4-r0ALPINE-CVE-2026-45692
Alpine:v3.24caddy2.11.4-r0ALPINE-CVE-2026-45692
Debian:12caddy2.6.2-5+deb12u1DEBIAN-CVE-2026-45692
Debian:13caddy2.6.2-12+deb13u1DEBIAN-CVE-2026-45692
Debian:14caddy2.11.4-1DEBIAN-CVE-2026-45692
Gogithub.com/caddyserver/caddy/v22.11.3GO-2026-5743
Gogithub.com/caddyserver/caddy/v22.11.3GHSA-x5w9-xh9r-mvfc
Ubuntu:25.10caddyno fix listedUBUNTU-CVE-2026-45692
Ubuntu:26.10caddyno fix listedUBUNTU-CVE-2026-45692

Affected products (as reported)

VendorProductVersions
caddyserver caddy >= 2.4.0, < 2.11.3

Weakness: CWE-187, CWE-863 · Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:N

References