Vulnerability · Published Aug 6, 2026 · Assigned by GitHub_M
CVE-2026-45573Decidim: Push subscriptions can be abused for server-side requests
Medium 6.4
In plain English
A medium-severity server-side request forgery in decidim from decidim. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.3% (higher than 18% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
Decidim is a participatory democracy framework. Prior to 0.30.9, from 0.31.0 before 0.31.5, and in 0.32.0.rc1 before 0.32.0.rc2, when VAPID delivery is enabled, the notification subscription flow stores a client-supplied push endpoint without validating that it belongs to an approved push service, and SendPushNotification later passes that endpoint to WebPush.payload_send, allowing an authenticated user to create stored, mostly blind server-side requests to arbitrary reachable HTTPS endpoints. This issue is fixed in versions 0.30.9, 0.31.5, and 0.32.0.rc2.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| RubyGems | decidim-core | 0.30.9 | GHSA-2g9c-vf8h-prxx |
| RubyGems | decidim-core | 0.31.5 | GHSA-2g9c-vf8h-prxx |
| RubyGems | decidim-core | 0.32.0 | GHSA-2g9c-vf8h-prxx |
Affected products (as reported)
Weakness: CWE-918 · Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:N
References
- https://github.com/decidim/decidim/security/advisories/GHSA-2g9c-vf8h-prxx x_refsource_CONFIRM
- https://github.com/decidim/decidim/pull/16714 x_refsource_MISC