Vulnerability · Published Jul 28, 2026 · Assigned by GitHub_M

CVE-2026-45293WordPress Coding Standards (WordPressCS) contains an arbitrary code execution vulnerability

High 8.6

In plain English

A high-severity security flaw in WordPress-Coding-Standards from WordPress. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.2% (higher than 16% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)8.6High
Exploit odds (30 days)0.2%top 83.7% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

WordPress Coding Standards is a set of PHP_CodeSniffer rules (sniffs) that enforce WordPress coding conventions. From 0.14.1 until 3.4.1, the WordPress.WP.EnqueuedResourceParameters sniff (active in the WordPress and WordPress-Extra rulesets) reconstructed the $ver argument passed to functions such as wp_enqueue_script() and ran it through eval() inside its is_falsy() method, so a maliciously crafted argument such as 'system'('id') would execute during a scan; as a result, running PHPCS with WordPressCS over untrusted PHP (for example a CI pipeline that lints pull requests, or a developer reviewing third-party code) could lead to arbitrary command execution on the scanning host. The WordPress-Core and WordPress-Docs rulesets are not affected. This issue is fixed in version 3.4.1.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Packagistwp-coding-standards/wpcs3.4.1GHSA-3pwp-g2mj-5p3v

Affected products (as reported)

VendorProductVersions
WordPress WordPress-Coding-Standards >= 0.14.1, < 3.4.1

Weakness: CWE-95 · Vector: CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:C/C:H/I:H/A:H

References