Vulnerability · Published Jun 5, 2026 · Assigned by GitHub_M
CVE-2026-45291Cloudburst Network erroneously handles invalid connections
High 7.5
In plain English
A high-severity improper input validation in Network from CloudburstMC. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.3% (higher than 18% of all known vulnerabilities).
Official description
Cloudburst Network provides network components used within Cloudburst projects. A vulnerability in versions prior to `1.0.0.CR3-20260418.124334-32` impacts publicly accessible software depending on the affected versions of Network and allows an attacker to exploit a bug in Network to close the parent netty channel, rendering it inoperable. All consumers of the library should upgrade to at least version `1.0.0.CR3-20260418.124334-32`. There are no known workarounds beyond updating the library.
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| CloudburstMC | Network | < 1.0.0.CR3-20260418.124334-32 |
Weakness: CWE-20 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
References
- https://github.com/CloudburstMC/Network/security/advisories/GHSA-rh6x-g5c8-2rmf x_refsource_CONFIRM