Vulnerability · Published May 14, 2026 · Assigned by apache

CVE-2026-45205Apache Commons Configuration: StackOverflowError for YAML input with cycles

Medium 5.3

In plain English

A medium-severity security flaw in Apache Commons Configuration from Apache Software Foundation. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.5% (higher than 41% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)5.3Medium
Exploit odds (30 days)0.5%top 59.2% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

Uncontrolled Recursion vulnerability in Apache Commons. When processing an untrusted configuration file, Commons Configuration will throw a StackOverflowError for YAML input with cycles. This issue affects Apache Commons: from 2.2 before 2.15.0. Users are recommended to upgrade to version 2.15.0, which fixes the issue.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Debian:12commons-configuration2no fix listedDEBIAN-CVE-2026-45205
Debian:13commons-configuration2no fix listedDEBIAN-CVE-2026-45205
Debian:14commons-configuration22.15.1-1DEBIAN-CVE-2026-45205
Mavenorg.apache.commons:commons-configuration22.15.0GHSA-337m-mw94-2v6g
Ubuntu:22.04:LTScommons-configurationno fix listedUBUNTU-CVE-2026-45205
Ubuntu:24.04:LTScommons-configurationno fix listedUBUNTU-CVE-2026-45205
Ubuntu:25.10commons-configurationno fix listedUBUNTU-CVE-2026-45205
Ubuntu:26.04:LTScommons-configurationno fix listedUBUNTU-CVE-2026-45205
Ubuntu:26.10commons-configurationno fix listedUBUNTU-CVE-2026-45205
Ubuntu:22.04:LTScommons-configuration2no fix listedUBUNTU-CVE-2026-45205
Ubuntu:24.04:LTScommons-configuration2no fix listedUBUNTU-CVE-2026-45205
Ubuntu:25.10commons-configuration2no fix listedUBUNTU-CVE-2026-45205
Ubuntu:26.04:LTScommons-configuration2no fix listedUBUNTU-CVE-2026-45205
Ubuntu:26.10commons-configuration2no fix listedUBUNTU-CVE-2026-45205

Affected products (as reported)

VendorProductVersions
Apache Software Foundation Apache Commons Configuration 2.2 – before 2.15.0

Weakness: CWE-674 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L

References