Vulnerability · Published Jun 23, 2026 · Assigned by GitHub_M

CVE-2026-45135Caddy: Unsafe Unicode Handling in FastCGI splitPos Allows Execution of Non-PHP Files

High 8.1

In plain English

A high-severity improper input validation in caddy from caddyserver. Proof-of-concept exploit code is public. The chance it is exploited in the next 30 days is estimated at 0.7% (higher than 52% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)8.1High
Exploit odds (30 days)0.7%top 47.6% of all CVEs
Exploited in the wildNo reportsCISA SSVC: poc
Attack toolingNoneno public tooling known

Official description

Caddy is an extensible server platform that uses TLS by default. From 2.7.0 until 2.11.3, the FastCGI transport's splitPos() in modules/caddyhttp/reverseproxy/fastcgi/fastcgi.go misuses golang.org/x/text/search with search.IgnoreCase when the request path contains a non-ASCII byte. Two distinct flaws in that fallback let an attacker mislead Caddy's FastCGI splitting into treating a non-.php (or other configured split_path extension) file as a script. In any deployment where the attacker can place content into a file served via FastCGI (uploads, file storage, etc.), this can be escalated to remote code execution by crafting a URL whose path triggers either flaw. This vulnerability is fixed in 2.11.3.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Alpine:v3.23caddy2.11.4-r0ALPINE-CVE-2026-45135
Alpine:v3.24caddy2.11.4-r0ALPINE-CVE-2026-45135
Debian:14caddy2.11.4-1DEBIAN-CVE-2026-45135
Gogithub.com/caddyserver/caddy/v22.11.3GO-2026-5492
Gogithub.com/caddyserver/caddy/v22.11.3GHSA-m675-2p33-xv9g
Ubuntu:25.10caddyno fix listedUBUNTU-CVE-2026-45135
Ubuntu:26.10caddyno fix listedUBUNTU-CVE-2026-45135

Affected products (as reported)

VendorProductVersions
caddyserver caddy >= 2.7.0, < 2.11.3

Weakness: CWE-20, CWE-176, CWE-178 · Vector: CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H

References