Vulnerability · Published Jul 14, 2026 · Assigned by GitHub_M

CVE-2026-45133Symfony: [Yaml] Harden the parser when handling untrusted input

High 8.2

In plain English

A high-severity regular-expression denial of service in symfony from symfony. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.6% (higher than 50% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 4.0)8.2High
Exploit odds (30 days)0.6%top 49.6% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

Symfony is a PHP framework for web and console applications and a set of reusable PHP components. Prior to 5.4.52, 6.4.40, 7.4.12, and 8.0.12, when the parser is exposed to attacker-controlled input, deeply nested mappings or sequences cause both the block-level (Parser::parseBlock()) and inline (Inline::parseSequence() / Inline::parseMapping()) parsers to recurse without a depth limit. A crafted document exhausts the PHP stack and crashes the worker. This issue is fixed in versions 5.4.52, 6.4.40, 7.4.12, and 8.0.12.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Debian:12symfony5.4.53+dfsg-0+deb12u1DEBIAN-CVE-2026-45133
Debian:13symfony6.4.41+dfsg-0+deb13u1DEBIAN-CVE-2026-45133
Debian:14symfony7.4.12+dfsg-1DEBIAN-CVE-2026-45133
Packagistsymfony/symfony7.4.12GHSA-c2p3-7m5p-cv8x
Packagistsymfony/symfony8.0.12GHSA-c2p3-7m5p-cv8x
Packagistsymfony/symfony5.4.52GHSA-c2p3-7m5p-cv8x
Packagistsymfony/symfony6.4.40GHSA-c2p3-7m5p-cv8x
Packagistsymfony/yaml5.4.52GHSA-c2p3-7m5p-cv8x
Packagistsymfony/yaml6.4.40GHSA-c2p3-7m5p-cv8x
Packagistsymfony/yaml7.4.12GHSA-c2p3-7m5p-cv8x
Packagistsymfony/yaml8.0.12GHSA-c2p3-7m5p-cv8x
Ubuntu:25.10symfonyno fix listedUBUNTU-CVE-2026-45133
Ubuntu:26.04:LTSsymfonyno fix listedUBUNTU-CVE-2026-45133
Ubuntu:26.10symfonyno fix listedUBUNTU-CVE-2026-45133

Affected products (as reported)

VendorProductVersions
symfony symfony < 5.4.52>= 6.0.0-BETA1, < 6.4.40>= 7.0.0-BETA1, < 7.4.12>= 8.0.0-BETA1, < 8.0.12

Weakness: CWE-674, CWE-776, CWE-1333 · Vector: CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N

References