Vulnerability · Published Jul 14, 2026 · Assigned by GitHub_M
CVE-2026-45065Symfony: UrlGenerator Route-Requirement Bypass via Unanchored Regex Alternation → Off-Site //host URL Injection
Low 2.3
In plain English
A low-severity open redirect in symfony from symfony. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.3% (higher than 29% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
Symfony is a PHP framework for web and console applications and a set of reusable PHP components. Prior to 5.4.52, 6.4.40, 7.4.12, and 8.0.12, UrlGenerator validates route parameters against a pattern built as ^ plus the raw requirement plus $; with ungrouped alternations, middle alternatives match as unanchored substrings, allowing a value such as //evil.com to satisfy a common locale requirement and generate a protocol-relative off-site URL. This issue is fixed in versions 5.4.52, 6.4.40, 7.4.12, and 8.0.12.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| Debian:12 | symfony | 5.4.53+dfsg-0+deb12u1 | DEBIAN-CVE-2026-45065 |
| Debian:13 | symfony | 6.4.41+dfsg-0+deb13u1 | DEBIAN-CVE-2026-45065 |
| Debian:14 | symfony | 7.4.12+dfsg-1 | DEBIAN-CVE-2026-45065 |
| Packagist | symfony/routing | 5.4.52 | GHSA-72xp-p242-47p9 |
| Packagist | symfony/routing | 6.4.40 | GHSA-72xp-p242-47p9 |
| Packagist | symfony/routing | 7.4.12 | GHSA-72xp-p242-47p9 |
| Packagist | symfony/routing | 8.0.12 | GHSA-72xp-p242-47p9 |
| Packagist | symfony/symfony | 8.0.12 | GHSA-72xp-p242-47p9 |
| Packagist | symfony/symfony | 5.4.52 | GHSA-72xp-p242-47p9 |
| Packagist | symfony/symfony | 6.4.40 | GHSA-72xp-p242-47p9 |
| Packagist | symfony/symfony | 7.4.12 | GHSA-72xp-p242-47p9 |
| Ubuntu:25.10 | symfony | no fix listed | UBUNTU-CVE-2026-45065 |
| Ubuntu:26.04:LTS | symfony | no fix listed | UBUNTU-CVE-2026-45065 |
| Ubuntu:26.10 | symfony | no fix listed | UBUNTU-CVE-2026-45065 |
Affected products (as reported)
Weakness: CWE-185, CWE-601 · Vector: CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:P/VC:N/VI:N/VA:N/SC:L/SI:L/SA:N
References
- https://github.com/symfony/symfony/security/advisories/GHSA-72xp-p242-47p9 x_refsource_CONFIRM
- https://github.com/symfony/symfony/releases/tag/v5.4.52 x_refsource_MISC
- https://github.com/symfony/symfony/releases/tag/v6.4.40 x_refsource_MISC
- https://github.com/symfony/symfony/releases/tag/v7.4.12 x_refsource_MISC
- https://github.com/symfony/symfony/releases/tag/v8.0.12 x_refsource_MISC