Vulnerability · Published Jul 14, 2026 · Assigned by GitHub_M
CVE-2026-45063Symfony: Identity Spoofing via Unanchored DN Regex in X509Authenticator
Critical 9.1
In plain English
A critical-severity authentication bypass by spoofing in symfony from symfony. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.3% (higher than 28% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
Symfony is a PHP framework for web and console applications and a set of reusable PHP components. Prior to 5.4.52, 6.4.40, 7.4.12, and 8.0.12, X509Authenticator extracts the user identifier from $_SERVER['SSL_CLIENT_S_DN'] with an unanchored regex that matches emailAddress= anywhere in the distinguished name, allowing an attacker with a trusted certificate containing emailAddress=victim inside another RDN value such as CN to authenticate as the victim. This issue is fixed in versions 5.4.52, 6.4.40, 7.4.12, and 8.0.12.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| Debian:12 | symfony | 5.4.53+dfsg-0+deb12u1 | DEBIAN-CVE-2026-45063 |
| Debian:13 | symfony | 6.4.41+dfsg-0+deb13u1 | DEBIAN-CVE-2026-45063 |
| Debian:14 | symfony | 7.4.12+dfsg-1 | DEBIAN-CVE-2026-45063 |
| Packagist | symfony/security-http | 5.4.52 | GHSA-ph86-p8f6-f9r2 |
| Packagist | symfony/security-http | 6.4.40 | GHSA-ph86-p8f6-f9r2 |
| Packagist | symfony/security-http | 7.4.12 | GHSA-ph86-p8f6-f9r2 |
| Packagist | symfony/security-http | 8.0.12 | GHSA-ph86-p8f6-f9r2 |
| Packagist | symfony/symfony | 8.0.12 | GHSA-ph86-p8f6-f9r2 |
| Packagist | symfony/symfony | 5.4.52 | GHSA-ph86-p8f6-f9r2 |
| Packagist | symfony/symfony | 6.4.40 | GHSA-ph86-p8f6-f9r2 |
| Packagist | symfony/symfony | 7.4.12 | GHSA-ph86-p8f6-f9r2 |
| Ubuntu:25.10 | symfony | no fix listed | UBUNTU-CVE-2026-45063 |
| Ubuntu:26.04:LTS | symfony | no fix listed | UBUNTU-CVE-2026-45063 |
| Ubuntu:26.10 | symfony | no fix listed | UBUNTU-CVE-2026-45063 |
Affected products (as reported)
Weakness: CWE-290 · Vector: CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:H/VI:H/VA:N/SC:N/SI:N/SA:N
References
- https://github.com/symfony/symfony/security/advisories/GHSA-ph86-p8f6-f9r2 x_refsource_CONFIRM
- https://github.com/symfony/symfony/commit/59ef484029601a7af06f5e06c6ed921fdcea5a0d x_refsource_MISC
- https://github.com/symfony/symfony/releases/tag/v5.4.52 x_refsource_MISC
- https://github.com/symfony/symfony/releases/tag/v6.4.40 x_refsource_MISC
- https://github.com/symfony/symfony/releases/tag/v7.4.12 x_refsource_MISC
- https://github.com/symfony/symfony/releases/tag/v8.0.12 x_refsource_MISC