Vulnerability · Published May 28, 2026 · Assigned by GitHub_M
CVE-2026-44849Portainer: Endpoint security bypass via Swarm service create/update
Critical 9.4
In plain English
A critical-severity missing authorization in portainer from portainer. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.4% (higher than 37% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
Portainer Community Edition is a lightweight service delivery platform for containerized applications that can be used to manage Docker, Swarm, Kubernetes and ACI environments. From 2.33.0 to before 2.33.8, 2.39.2, and 2.41.0, Portainer enforces seven EndpointSecuritySettings restrictions that administrators configure to restrict the container configurations non-admin users can launch: privileged mode, host PID namespace, device mapping, capabilities, sysctls, security-opt (Seccomp / AppArmor), and bind mounts. These restrictions are enforced on the standard container creation path, but several of them are not applied on the Docker Swarm service API. This vulnerability is fixed in 2.33.8, 2.39.2, and 2.41.0.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| Go | github.com/portainer/portainer | 2.33.8 | GHSA-5fxq-qcf3-244w |
| Go | github.com/portainer/portainer | 2.39.2 | GHSA-5fxq-qcf3-244w |
| Go | github.com/portainer/portainer | 2.41.0 | GHSA-5fxq-qcf3-244w |
| Go | github.com/portainer/portainer | no fix listed | GO-2026-5143 |
Affected products (as reported)
Weakness: CWE-862 · Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:H/SC:H/SI:H/SA:H
References
- https://github.com/portainer/portainer/security/advisories/GHSA-5fxq-qcf3-244w x_refsource_CONFIRM