Vulnerability · Published May 11, 2026 · Assigned by GitHub_M
CVE-2026-44643Angular Expressions - Remote Code Execution using filters
Critical 9.3
In plain English
A critical-severity security flaw in angular-expressions from peerigon. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.5% (higher than 41% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
Angular Expressions provides expressions for the Angular.JS web framework as a standalone module. Prior to 1.5.2, an attacker can write a malicious expression using filters that escapes the sandbox to execute arbitrary code on the system. This vulnerability is fixed in 1.5.2.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| npm | angular-expressions | 1.5.2 | GHSA-pw8r-6689-xvf4 |
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| peerigon | angular-expressions | < 1.5.2 |
Weakness: CWE-95 · Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N