Vulnerability · Published May 13, 2026 · Assigned by GitHub_M
CVE-2026-44581Next.js: Cross-site scripting in App Router applications using CSP nonces
Medium 4.7
In plain English
A medium-severity cross-site scripting in next.js from vercel. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.2% (higher than 13% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
Next.js is a React framework for building full-stack web applications. From 13.4.0 to before 15.5.16 and 16.2.5, App Router applications that rely on CSP nonces can be vulnerable to stored cross-site scripting when deployed behind shared caches. In affected versions, malformed nonce values derived from request headers could be reflected into rendered HTML in an unsafe way, allowing an attacker to poison cached responses and cause script execution for later visitors. This vulnerability is fixed in 15.5.16 and 16.2.5.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| npm | next | 15.5.16 | GHSA-ffhc-5mcf-pf4q |
| npm | next | 16.2.5 | GHSA-ffhc-5mcf-pf4q |
Affected products (as reported)
Weakness: CWE-79 · Vector: CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:C/C:L/I:L/A:N
References
- https://github.com/vercel/next.js/security/advisories/GHSA-ffhc-5mcf-pf4q x_refsource_CONFIRM