Vulnerability · Published Jun 8, 2026 · Assigned by GitHub_M

CVE-2026-44541Fides: DOM-based XSS vulnerability in fides.js via fides_description override

High 7.0

In plain English

A high-severity cross-site scripting in fides from ethyca. Proof-of-concept exploit code is public. The chance it is exploited in the next 30 days is estimated at 0.3% (higher than 23% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 4.0)7.0High
Exploit odds (30 days)0.3%top 77.5% of all CVEs
Exploited in the wildNo reportsCISA SSVC: poc
Attack toolingNoneno public tooling known

Official description

Fides is an open-source privacy engineering platform. From version 2.33.0 to before version 2.84.5, there is a DOM-based XSS vulnerability in fides.js via the fides_description override. This issue has been patched in version 2.84.5.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
PyPIethyca-fides2.84.5GHSA-5qrq-9645-g5g2
PyPIethyca-fides2.84.5PYSEC-2026-2470

Affected products (as reported)

VendorProductVersions
ethyca fides >= 2.33.0, < 2.84.5

Weakness: CWE-79 · Vector: CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:N/VI:N/VA:N/SC:H/SI:H/SA:N

References