Vulnerability · Published May 12, 2026 · Assigned by GitHub_M
CVE-2026-44167phpseclib: CVE-2024-27355 mitigation bypass — OID amplification DoS in ASN1::decodeOID()
High 7.5
In plain English
A high-severity uncontrolled resource consumption in phpseclib from phpseclib. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.2% (higher than 10% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Severity (CVSS 3.1)7.5High
Exploit odds (30 days)0.2%top 90.0% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known
Official description
phpseclib is a PHP secure communications library. Prior to 1.0.29, 2.0.54, and 3.0.52, anyone loading untrusted ASN1 files (eg. X509 certificates, RSA PKCS8 private or public keys, etc). This is a bypass of CVE-2024-27355. This vulnerability is fixed in 1.0.29, 2.0.54, and 3.0.52.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| Debian:12 | php-phpseclib | 2.0.42-1+deb12u5 | DEBIAN-CVE-2026-44167 |
| Debian:13 | php-phpseclib | 2.0.48-3+deb13u3 | DEBIAN-CVE-2026-44167 |
| Debian:14 | php-phpseclib | 2.0.54-1 | DEBIAN-CVE-2026-44167 |
| Debian:12 | php-phpseclib3 | 3.0.19-1+deb12u6 | DEBIAN-CVE-2026-44167 |
| Debian:13 | php-phpseclib3 | 3.0.43-2+deb13u3 | DEBIAN-CVE-2026-44167 |
| Debian:14 | php-phpseclib3 | 3.0.52-1 | DEBIAN-CVE-2026-44167 |
| Debian:12 | phpseclib | 1.0.20-1+deb12u5 | DEBIAN-CVE-2026-44167 |
| Debian:13 | phpseclib | 1.0.23-6+deb13u3 | DEBIAN-CVE-2026-44167 |
| Packagist | phpseclib/phpseclib | 2.0.54 | GHSA-3qpq-r242-jqj7 |
| Packagist | phpseclib/phpseclib | 1.0.29 | GHSA-3qpq-r242-jqj7 |
| Packagist | phpseclib/phpseclib | 3.0.52 | GHSA-3qpq-r242-jqj7 |
| Ubuntu:25.10 | php-phpseclib | no fix listed | UBUNTU-CVE-2026-44167 |
| Ubuntu:24.04:LTS | php-phpseclib3 | no fix listed | UBUNTU-CVE-2026-44167 |
| Ubuntu:25.10 | php-phpseclib3 | no fix listed | UBUNTU-CVE-2026-44167 |
| Ubuntu:26.04:LTS | php-phpseclib3 | no fix listed | UBUNTU-CVE-2026-44167 |
| Ubuntu:26.10 | php-phpseclib3 | no fix listed | UBUNTU-CVE-2026-44167 |
| Ubuntu:22.04:LTS | phpseclib | no fix listed | UBUNTU-CVE-2026-44167 |
| Ubuntu:25.10 | phpseclib | no fix listed | UBUNTU-CVE-2026-44167 |
| Ubuntu:26.10 | phpseclib | no fix listed | UBUNTU-CVE-2026-44167 |
Affected products (as reported)
Weakness: CWE-400 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H